Ask Your Question
0

Error add user in group

asked 2016-08-30 04:28:04 -0500

marawu gravatar image

Hi, i want add user in group. I add in site.pp:

user { 'admin': groups => 'wheel'}

When run puppet agent --test i have it:

WS0000:~ root# puppet agent --test
Info: Using configured environment 'development'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching catalog for ws0000.local
Info: Applying configuration version '1472548837'
Error: Unknown failure comparing values _appserveradm,_appserverusr,_lpadmin,admin,com.apple.sharepoint.group.1,wheel and ["_appserveradm", "_appserverusr", "_lpadmin", "admin", "com.apple.sharepoint.group.1"] using insync? on type: User[admin] property: groups
Error: /Stage[main]/Main/User[admin]: Could not evaluate: Group names must be provided as an array, not a comma-separated list.
Notice: Applied catalog in 5.79 seconds

I use OS X 10.11.6

edit retag flag offensive close merge delete

Comments

1

what version of puppet?

DarylW gravatar imageDarylW ( 2016-08-30 07:46:38 -0500 )edit

@DarylW i use 4.6.1 version

marawu gravatar imagemarawu ( 2016-08-30 10:12:57 -0500 )edit

don't place resources into `site.pp`

Kai Burghardt gravatar imageKai Burghardt ( 2016-09-03 19:00:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-08-30 12:49:23 -0500

lupin gravatar image

Interesting, on version 3.7 the syntax you pasted works. Try changing the value of groups parameter to an Array. i.e

user { 'admin':
    ensure => 'present',
    groups => ['wheel'],
}
edit flag offensive delete link more

Comments

sorry, it did not help

marawu gravatar imagemarawu ( 2016-08-31 03:07:13 -0500 )edit
1

answered 2016-09-12 08:03:40 -0500

tequeter gravatar image

updated 2016-09-16 09:07:02 -0500

We had a similar issue on unrelated resource types:

Unknown failure comparing values system_u and unconfined_u using insync? on type: File[/opt/...] property: seluser
Unknown failure comparing values running and stopped using insync? on type: Service[xxx.service] property: ensure

In our case, it was caused by a Puppet Server RPM update to 4.6.2 without restarting the service.

-> Try restarting the "puppetserver" service if you recently upgraded.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-30 04:28:04 -0500

Seen: 187 times

Last updated: Sep 16 '16