Puppet agent slow on "Starting connection for https://puppet:8140"

asked 2016-08-30 11:06:15 -0600

RCMMike gravatar image

updated 2016-08-30 11:17:21 -0600

Version 4 setup on both master and agents.

My Puppet agents have been running slowly, and debug seems to be pointing to:

Debug: Starting connection for https://puppet:8140

It seems to pause for up to 20 seconds here before finally establishing the connection and continuing.

I'm not showing any real data in the logs on either the client or the master. Anything I should look for?

I ran puppet agent -t --noop --evaltrace --summarize with these results:

Notice: Applied catalog in 70.85 seconds
Changes:
Events:
Resources:
            Total: 284
Time:
       Filebucket: 0.00
             Host: 0.00
   Concat fragment: 0.00
      Concat file: 0.00
         Schedule: 0.00
          Yumrepo: 0.01
             User: 0.01
           Anchor: 0.02
        File line: 0.07
          Package: 0.16
   Firewalld zone: 1.09
         Last run: 1472573666
            Total: 156.92
   Firewalld service: 3.00
          Service: 3.12
             File: 36.29
           Augeas: 6.69
             Exec: 8.76
   Config retrieval: 97.70
Version:
           Config: 1472573577
           Puppet: 4.6.1
edit retag flag offensive close merge delete

Comments

DNS is always something to check. Ensure that your DNS resolvers are available, respond quickly and have "puppet" pointing to (of course) your puppet master. Try putting the IP address of your master in /etc/hosts and see if that makes things faster. Also, "ping puppet" and check response.

bschonecker gravatar imagebschonecker ( 2016-08-31 17:38:39 -0600 )edit