Ask Your Question
0

Error with PuppetDB 4.1 (PE 2016.2) HTTP API with RBAC token authentication

asked 2016-08-30 14:04:27 -0600

I am trying to use RBAC token to access the PuppetDB HTTP API with the following command:

curl -X GET https://learning.puppetlabs.vm:8081/pdb/query/v4/nodes -H "X-Authentication: $TOKEN" --cacert /path_to/ca.pem --tlsv1 -v

However, I received this error. Output:

curl: (35) Unknown SSL protocol error in connection to learning.puppetlabs.vm:8081

I can use similar command on other services and it is working as expected:

curl -X GET https://learning.puppetlabs.vm:4433/status/v1/services -H "X-Authentication: $TOKEN" --cacert /path_to/ca.pem --tlsv1 -v

Output:

{"classifier-service":{"service_version":"1.7.10","service_status_version":1,"detail_level":"info","state":"running","status":{"db_up":true,"db_pool":{"state":"ready"},"rbac_up":true,"activity_up":true}},"activity-service":{"service_version":"0.5.3","service_status_version":1,"detail_level":"info","state":"running","status":{"db_up":true}},"rbac-service":{"service_version":"1.2.18","service_status_version":1,"detail_level":"info","state":"running","status":{"db_up":true,"activity_up":true}}}

Please advise

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-12 14:40:09 -0600

I asked the question on IRC and here is the answer from @arowtker

PuppetDB needs to be configured with client-auth: want under the [jetty] header of jetty.ini

Archive: IRC Archive

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-30 14:04:27 -0600

Seen: 63 times

Last updated: Sep 12 '16