How to apply GNOME settings to current session?

asked 2016-08-31 09:31:12 -0500

l0b0 gravatar image

updated 2016-08-31 11:14:35 -0500

This procedure makes windows in the background raise (that is, appear in the foreground) when clicked:

  1. Log in to Fedora 24
  2. Open a terminal
  3. Run gsettings set org.gnome.desktop.wm.preferences raise-on-click true

If I put the same command in an exec it does not apply to the current session, and it is not saved for the next session. That is, even after logging out and in again it does not apply. Is there some environment or other setting I can use to ensure that this setting really is saved when running Puppet?

I've tried (and would prefer it over using exec if it can be made to work) puppet-gnome, but I can't get any settings to work with it. Presumably either the override method used there is either obsolete or incorrect in some other way.

I can't find documentation specifically for overriding settings in GNOME 3.20, and I don't know which folder GNOME actually monitors for overrides (or how to apply them). Any of these pieces of information would also be useful in getting somewhere.

Related question

edit retag flag offensive close merge delete

Comments

I'm afraid you can't. You've gotta configure Gnome via its configuration files. Then restart.

Kai Burghardt gravatar imageKai Burghardt ( 2016-09-03 18:54:11 -0500 )edit