Ask Your Question
1

puppet enterprise console not showing all paramaters for apache class

asked 2016-09-07 00:22:19 -0500

stuartd gravatar image

new to puppet. Trying to classify a group within puppet enterprise console (the web interface to puppet) and having limited success.

I am able to add the apache class to a group (after installing this module: https://forge.puppet.com/puppetlabs/a...), and pin it to a node/agent and apache successfully installs on the agents.

However some paramaters/options can not be set from within puppet enterprise console. For instance I can find no way to apache::vhost or add any paramaters to it.

I have also experienced this problem with other modules from the forge. I know I could write my own manifests and include them, but trying to utilize the web UI as much as possible (for a future sys admin to take over).

OS is Ubuntu 16.0.4 on master and agents.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2016-09-07 13:14:53 -0500

lavaman gravatar image

This is because apache::vhost is a defined type, not a class. Only classes can be assigned to nodes in the console (or any other ENC). Defined types are meant to be used in manifest code like any other language type (file, exec, etc.)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-07 00:22:19 -0500

Seen: 46 times

Last updated: Sep 07 '16