Ask Your Question
1

$osfamily not defined?

asked 2013-09-01 07:16:19 -0500

ethrbunny gravatar image

updated 2013-09-02 07:11:43 -0500

I'm trying to use the PuppetLabs mysql module from Puppet Forge. It worked fine on Debian 7.x but is failing on v6.x as the $osfamily fact appears to be undefined.

err: Could not retrieve catalog from remote server: Error 400 on SERVER: 
   Unsupported osfamily:  operatingsystem: Debian, module mysql only support 
   osfamily RedHat, Debian, and FreeBSD, or operatingsystem Amazon at 
   /etc/puppet/modules/mysql/manifests/params.pp:186 on node client-003.dom

Line from the module:

default: {
      fail("Unsupported osfamily: ${::osfamily} operatingsystem: ${::operatingsystem}, 
      module ${module_name} only support osfamily RedHat, Debian, and FreeBSD, 
      or operatingsystem Amazon")

Is there a ... (more)

edit retag flag offensive close merge delete

Comments

What version of Puppet/facter do you have installed on the client?

nibalizer gravatar imagenibalizer ( 2013-09-01 14:32:34 -0500 )edit

Why haven't you installed a recent version of facter. 1.7.2 which is available for your distro from apt.puppetlabs.com instead of modifying code?

ramindk gravatar imageramindk ( 2013-09-02 12:49:23 -0500 )edit

As I mentioned - the module doesn't support this build of the OS anyway so it's a moot point.

ethrbunny gravatar imageethrbunny ( 2013-09-03 07:56:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
4

answered 2013-09-01 16:42:34 -0500

ramindk gravatar image

updated 2013-09-03 12:29:04 -0500

This is usually caused by older version of Facter.

It appears that Debian Squeeze installs Facter 1.5.x by default. The $::osfamily fact was introduced in Facter 1.6 which ships in Wheezy.

I recommend pulling a more recent packages from Puppetlabs into your local repo and using it across the board rather than dealing with disparate versions across your infrastructure.

edit flag offensive delete link more
0

answered 2013-09-01 08:02:16 -0500

Willi gravatar image

updated 2013-09-01 08:02:40 -0500

have u tryed to install debian package "lsb-release" first?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-01 07:16:19 -0500

Seen: 1,083 times

Last updated: Sep 03 '13