Ask Your Question
0

Connection Issues on Puppet

asked 2016-09-21 10:14:14 -0500

JamesHailey gravatar image

updated 2016-09-21 10:20:30 -0500

When I do puppet agent -t on the agent, I am seeing the following. It happened recently all of a sudden. Few things to mention: 1. The Puppet master and agents are all up and running. 2. The certificate is successfully signed. Puppet master version 4.3.1 Puppet agent version 3.8.4 OS RedHat, 6 on master, 7 on some agents.

Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Connection refused - connect(2)
Info: Retrieving pluginfacts
Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'eval_generate': Connection refused - connect(2)
Error: /File[/var/lib/puppet/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet://vengcjn501.mmm.com/pluginfacts: Connection refused - connect(2)
Info: Retrieving plugin
Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate': Connection refused - connect(2)
Error: /File[/var/lib/puppet/lib]: Could not evaluate: Could not retrieve file metadata for puppet://vengcjn501.mmm.com/plugins: Connection refused - connect(2)
Info: Loading facts
Error: Could not retrieve catalog from remote server: Connection refused - connect(2)
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
Error: Could not send report: Connection refused - connect(2)
edit retag flag offensive close merge delete

Comments

What troubleshooting have you done so far? Have you tried pinging the puppet master server from the agent node? Any firewall changes recently?

maynero gravatar imagemaynero ( 2016-09-21 13:31:18 -0500 )edit

hello, yes I have tried pinging and it's fine. The firewall wasn't changed other than the RedHat version.

JamesHailey gravatar imageJamesHailey ( 2016-09-27 10:14:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-21 19:37:41 -0500

PP pre 4.x and PP 4.x aren't compatible with each other.

edit flag offensive delete link more

Comments

Incorrect, you CAN use 3.x agents with a 4.x master, but I think the compatibility for it wasn't added (to puppet server only, not puppetmaster) till around 4.5.1

DarylW gravatar imageDarylW ( 2016-09-22 23:38:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-09-21 10:14:14 -0500

Seen: 82 times

Last updated: Sep 21 '16