Ask Your Question
0

Puppet server service not starting in centos 7

asked 2016-09-26 11:59:11 -0500

vidyasagar.reddy66@gmail.com gravatar image

updated 2016-09-26 13:05:47 -0500

DarylW gravatar image

Hi,

Puppet server service not starting in centos 7. Please help below is the log details and config files

Server: puppet.asicdesigners.com

Service staus:

● puppetserver.service - puppetserver Service
   Loaded: loaded (/usr/lib/systemd/system/puppetserver.service; disabled; vendor preset: disabled)
   Active: activating (start-post) since Mon 2016-09-26 17:07:09 IST; 26s ago
  Process: 6694 ExecStartPre=/usr/bin/install --directory --owner=puppet --group=puppet --mode=775 /var/run/puppetlabs/puppetserver (code=exited, status=0/SUCCESS)
 Main PID: 6696 (java);         : 6697 (bash)
   CGroup: /system.slice/puppetserver.service
           ├─6696 /usr/bin/java -Xms2g -Xmx2g -XX:MaxPermSize=256m -XX:OnOutOfMemoryError=kill -9 %p -Djava.security.egd=/dev/urandom -cp /opt/puppetlabs/server/apps/puppetserver/puppet-server-release.jar c...
           └─control
             ├─6697 /bin/bash /opt/puppetlabs/server/apps/puppetserver/ezbake-functions.sh wait_for_app
             └─6847 sleep 1

Sep 26 17:07:09 puppet.asicdesigners.com systemd[1]: Starting puppetserver Service...
Sep 26 17:07:09 puppet.asicdesigners.com java[6696]: OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

log file output

2016-09-26 17:08:20,584 INFO  [async-dispatch-2] [p.t.s.w.jetty9-core] Shutting down web server.
2016-09-26 17:08:20,586 INFO  [async-dispatch-2] [o.e.j.s.ServerConnector] Stopped ServerConnector@10496c61{SSL-HTTP/1.1}{0.0.0.0:8140}
2016-09-26 17:08:20,587 INFO  [async-dispatch-2] [o.e.j.s.h.ContextHandler] Stopped o.e.j.s.h.ContextHandler@2e443239{/puppet,null,UNAVAILABLE}
2016-09-26 17:08:20,587 INFO  [async-dispatch-2] [o.e.j.s.h.ContextHandler] Stopped o.e.j.s.h.ContextHandler@6bed5e38{/,null,UNAVAILABLE}
2016-09-26 17:08:20,587 INFO  [async-dispatch-2] [o.e.j.s.h.ContextHandler] Stopped o.e.j.s.h.ContextHandler@22aa1e14{/puppet-admin-api,null,UNAVAILABLE}
2016-09-26 17:08:20,587 INFO  [async-dispatch-2] [o.e.j.s.h.ContextHandler] Stopped o.e.j.s.h.ContextHandler@5ef6f488{/puppet-ca,null,UNAVAILABLE}
2016-09-26 17:08:20,592 INFO  [async-dispatch-2] [p.t.s.w.jetty9-core] Web server shutdown
2016-09-26 17:08:20,593 ERROR [async-dispatch-2] [p.t.internal] Error during service start!!!
java.net.BindException: Address already in use
    at sun.nio.ch.Net.bind0(Native Method)
    at sun.nio.ch.Net.bind(Net.java:433)
    at sun.nio.ch.Net.bind(Net.java:425)
    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
    at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:321)
    at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80)
    at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:236)
    at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
    at org.eclipse.jetty.server.Server.doStart(Server.java:366)
    at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at clojure.lang.Reflector.invokeMatchingMethod(Reflector.java:93)
    at clojure.lang.Reflector.invokeNoArgInstanceMember(Reflector.java:313)
    at puppetlabs.trapperkeeper.services.webserver.jetty9_core ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-09-26 13:43:00 -0500

cprice404 gravatar image

The error that you included sounds like there is already an application running on port 8140. Also, Puppet Server contains an embedded web server that replaces the older Apache/Passenger setup, so, since you've included your passenger configuration files I suspect that what may be happening is that Apache has already bound port 8140 by the time you attempt to start the Puppet Server service.

edit flag offensive delete link more

Comments

Thanks a lot It got fixed after i changed port to 8080 in puppetmaster and how do we access through pupet using web (Exact url).

vidyasagar.reddy66@gmail.com gravatar imagevidyasagar.reddy66@gmail.com ( 2016-09-26 17:28:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-26 11:59:11 -0500

Seen: 97 times

Last updated: Sep 26 '16