Ask Your Question
0

Foreman : Connection refused - connect(2) when I try to edit an host

asked 2016-09-28 04:01:15 -0600

Imagin0s gravatar image

updated 2016-09-28 08:30:30 -0600

DarylW gravatar image

Hello,

I have an error when I try to edit some hosts in Foreman. I have the following message : "Connection refused - connect(2)"

Here is the complete stacktrace :

Errno::ECONNREFUSED
Connection refused - connect(2)
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:763:in `initialize'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:763:in `open'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:763:in `block in connect'
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:100:in `timeout'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:763:in `connect'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:756:in `do_start'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:751:in `start'
/opt/theforeman/tfm/root/usr/share/gems/gems/rbvmomi-1.8.2/lib/rbvmomi/trivial_soap.rb:56:in `restart_http'
/opt/theforeman/tfm/root/usr/share/gems/gems/rbvmomi-1.8.2/lib/rbvmomi/trivial_soap.rb:20:in `initialize'
/opt/theforeman/tfm/root/usr/share/gems/gems/rbvmomi-1.8.2/lib/rbvmomi/connection.rb:31:in `initialize'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-1.34.0/lib/fog/vsphere/compute.rb:425:in `new'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-1.34.0/lib/fog/vsphere/compute.rb:425:in `block in connect'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-1.34.0/lib/fog/vsphere/compute.rb:423:in `loop'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-1.34.0/lib/fog/vsphere/compute.rb:423:in `connect'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-1.34.0/lib/fog/vsphere/compute.rb:394:in `initialize'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.32.1/lib/fog/core/service.rb:115:in `new'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.32.1/lib/fog/core/service.rb:115:in `new'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.32.1/lib/fog/core/services_mixin.rb:16:in `new'
/opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.32.1/lib/fog/compute.rb:62:in `new'
/usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:442:in `client'
/usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:431:in `dc'
/usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:76:in `networks'
/usr/share/foreman/app/views/compute_resources_vms/form/vmware/_network.html.erb:1:in `_app_views_compute_resources_vms_form_vmware__network_html_erb___866604012266222278_70272721042960'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:145:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:125:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:143:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:265:in `render_partial'
/opt/rh/ruby193/root/usr/share/gems/gems ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-30 02:51:05 -0600

domcleal gravatar image

The VMware compute resource that the host was created on is inaccessible - connection refused. It's down, permanently gone or inaccessible due to a firewall etc.

You can remove the association between the host and the compute resource, allowing the host to be edited like a bare metal host by using the checkboxes on the host list, then selecting Disassociate Hosts from the Select Action menu in the top-right corner. Since the link between them is lost, note that this means the VM will not be deleted when the Foreman host is deleted.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-09-28 04:01:15 -0600

Seen: 194 times

Last updated: Sep 30 '16