Package APT provider specify target-release

asked 2016-10-02 08:50:11 -0600

updated 2016-10-02 10:34:52 -0600

How do I achieve in PP a

apt-get install -t jessie-backports systemd

Only systemd and its dependencies shall come from jessie-backports. Everything else still comes from stable. No, I definitely won't specify a version number in Package['systemd']['ensure']

apt-get install systemd/jessie-backports is not a solution. It'll remove linux-image and dozens of applications packages (like xserver).

I looked, whether a apt::pin would help, but there you'd have to specify all packages by name, which I won't. As far as I've looked you can't specify a pin, „package systemd and all its dependencies“.

install_options don't solve the problem either. I guess they're only considered during the initial installation, not when I do an ensure => latest.

PS: Yes, I know mixing testing, backports, and stable all together can lead to problems. Yes, I know systemd sucks.

edit retag flag offensive close merge delete