New hiera with old puppet

asked 2016-10-06 04:45:30 -0500

C.P.A.vanrun gravatar image

Hello,

I'm trying to get hiera 3.x to work with Puppet 3.7.2 (which comes with hiera 1.3.4). The main reason being what I want to get deep_merge knockout behavior working via hiera.

However, installing the hiera gem via

gem install hiera

Results in an update command-line interface version of hiera but puppet keeps using the 1.3.4 installation. I cannot for the life of me find the configuration setting which tells puppet what hiera to use.

If anyone has any clue I'd be forever grateful.

Yours kindly,

Chris

edit retag flag offensive close merge delete