Ask Your Question
0

r10k deploy connection refused error [closed]

asked 2016-10-18 10:25:57 -0500

I am all out of options. r10k deploy environment works fine. r10k deploy environment dev works fine. But r10k deploy environment dev --puppetfile fails for all the modules from forge. I tried adding proxy settings in r10k.yaml but that didn't fix it.

Please provide pointers/examples as to how to fix it.

  myServer:/etc/puppetlabs/code/environments/dev/modules/testr10k #sudo r10k deploy environment dev --puppetfile
  ERROR    -> Unable to connect to https://forgeapi.puppetlabs.com: Connection refused - connect(2) for "forgeapi.puppetlabs.com" port 443

Puppetfile:

  forge "http://forge.puppet.com"
  #Puppetlabs forge modules
  mod 'puppetlabs/stdlib'
  mod 'puppetlabs/apt'
  mod 'puppetlabs/accounts'
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Redsmile
close date 2016-10-28 14:35:05.685847

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-18 18:11:43 -0500

lavaman gravatar image

According to the docs, running r10k in debug mode will show the proxy server being used, if any.

edit flag offensive delete link more
0

answered 2016-10-20 02:48:16 -0500

tomasl gravatar image

updated 2016-10-20 02:48:35 -0500

What if you try to export your proxy setting first?

export http_proxy=http://your.proxy.tld:<port>
export https_proxy=http://your.proxy.tld:<port>
edit flag offensive delete link more

Comments

Yes, i tried adding proxy in the env_var level, it didn't do the trick. It finally worked when i added the proxy: http://your.proxy.tld:<port> through the r10k module itself. r10k module has an additional setting called proxy that we can set for forge modules. thanks for your help!

Redsmile gravatar imageRedsmile ( 2016-10-28 14:34:45 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-10-18 10:25:57 -0500

Seen: 91 times

Last updated: Oct 20 '16