Ask Your Question
0

Windows agent help with proxy authentication settings

asked 2016-11-07 11:06:41 -0500

dt_puppet gravatar image

I have a Windows server running an agent which sits behind a proxy that requires username and password authentication. When I perform a "puppet agent -t" run, I am am getting 407 Proxy Authentication errors.

However, if I configure the agent to use a proxy that doesn't require authentication I get a successful run.

I am try to find out if proxy authentication is supported in the Windows client/agent.

Here is the configuration I am using:

Puppet Client v3.8.2

Puppet Config:

[main] server=puppet.domain.com

pluginsync=true

autoflush=true

environment=production

masterport = 443

ca_server = puppetca.domain.com

stringify_facts = false

pluginsync_facts = true

[agent]

httpproxyhost = proxy.domain.com

httpproxyport = 8080

httpproxyuser = proxyuser

httpproxypassword = proxypassword

report = true

certificate_revocation = false

Thank you for any help provided.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-04-11 11:58:54 -0500

dt_puppet gravatar image

Response from PuppetLabs:

I dug into this a bit and found out that those settings are intended to route all HTTP traffic through the proxy, however there is an outstanding issue with authenticated proxies. The ticket is here: https://tickets.puppetlabs.com/browse...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-07 10:58:40 -0500

Seen: 199 times

Last updated: Apr 11