Ask Your Question
0

I can't Compile the facter ! Why! Help !

asked 2016-11-24 02:17:34 -0500

CYK gravatar image

updated 2016-11-24 05:03:00 -0500

I have hundreds of freebsd 9.3 machine try to use puppet 4 and facter 3, but i got some trouble. Here are the platform information:

gcc version: 4.9.2 facter version: 3.4.1

OS : FreeBSD 9.3

``` ERROR: image description

```

Could anyone help me ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-24 04:32:06 -0500

have you followed the installation instructions for your platform? facter

do you need to compile from source for a specific reason - generally there are precompiled packages for most platforms ..

edit flag offensive delete link more

Comments

I compiled it for freebsd. I have hundreds of machines try to use puppet 4 on FreeBSD.

CYK gravatar imageCYK ( 2016-11-24 05:00:32 -0500 )edit

puppet 4 is available in bsd ports - give that a go?

sahumphries gravatar imagesahumphries ( 2016-11-24 07:40:32 -0500 )edit

Do you know the one from bsd ports use which version of facter?

CYK gravatar imageCYK ( 2016-11-24 10:27:55 -0500 )edit

FreeBSD 10.2-RELEASE here, installed `sysutils/puppet4`, got facter version `2.4.4`. Modern facts came with facter v3. So depending on, whether you already rely on modern facts, it's too old. The latest port `sysutils/puppet4` version `4.6.2` depends on `rubygem-facter-2.4.6`. That's still too old.

Kai Burghardt gravatar imageKai Burghardt ( 2016-11-24 14:07:20 -0500 )edit

That's too old.

CYK gravatar imageCYK ( 2016-11-24 20:42:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-24 02:17:34 -0500

Seen: 45 times

Last updated: Nov 24 '16