Ask Your Question
0

applying manifest on Windows

asked 2016-12-07 06:22:27 -0500

Anil Veeramalli gravatar image

updated 2016-12-07 12:05:10 -0500

lupin gravatar image

when i try to apply windows manifest, I am getting this error on windows

Error: Failed to apply catalog: Parameter creates failed on Exec[create repo_dir]: creates must be a fully qualified path at /opt/puppetlabs/puppet/modules/pe_repo/manifests/init.pp:47

when i look into opt/puppetlabs/puppet/modules/pe_repo/manifests/init.pp file i see line 47 has below code

exec { 'create repo_dir':
    command => "mkdir -p ${repo_dir}",
    creates => $repo_dir,
    path    => '/sbin/:/bin/',
  }

Please suggest me the solution on this.

edit retag flag offensive close merge delete

Comments

Hi sorry! Did you managed to solve this error? I am facing the same error! =(

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-22 20:43:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-07 12:08:32 -0500

lupin gravatar image

The exec resource is executing a command mkdir -p. I believe the -p option isn't available in Windows? And you need to supply the path value with correct file-system path on Windows which the mkdir is located.ie, C:\Windows\system32

edit flag offensive delete link more

Comments

Hi Lupin, Sorry to disturb you. I tried taking away the "-p" flag and modify the path, but I am still getting a error: Parameter path failed on path File[/opt/puppetlabs/server/data/packages]: File paths use be fully qualified, not '/opt/puppetlabs/server/data/packages' at /opt/puppetlabs/puppet/..

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-22 21:10:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-12-07 06:22:27 -0500

Seen: 150 times

Last updated: Dec 07 '16