Ask Your Question
0

Parameter path failed on File[/etc/puppetlabs/analytics-opt-out]: File paths must be fully qualified, not '/etc/puppetlabs/analytics-opt-out' at /opt/puppetlabs/puppet/modules/puppet_enterprise/manifests/profile/console.pp:164

asked 2016-12-13 14:29:40 -0500

Hello Team,

I have set up PE server on CentOS 6.8 and one of my Puppet agent is on CentOS and couple of agents are running on windows(8.1 and server 2012). I am getting the above error when ever the agents on Windows gets refreshed. I haven't found any solution for this kind of error. I have no issues with agents running on Linux.

These are the lines where I am getting this issue.

We need this check here, otherwise on a mono-install
we will have a duplicate file resource.
if $master_certname != $certname {
$analytics_opt_out_ensure = $send_analytics_data ? {
true  => absent,
false => file,
}

file { '/etc/puppetlabs/analytics-opt-out':
ensure  => $analytics_opt_out_ensure,
require => Package['pe-console-services']
}
}

Can Someone please help me out in resolving this issue.

Regards,

Sathvik

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-14 13:38:04 -0500

Hi Sathvik,

Can you please give us a little more context about your environment? What version of Puppet Enterprise are you running? Are you running an all in one PE installation (i.e. everything on a single node)? That code is related to the PE puppet module, and should only be applied to all-in-one PE hosts, or a single host that runs the PE console if it's a split install. In other words your windows agents shouldn't ever be applying that code. Perhaps you classified your windows agents as console nodes in the PE Console group?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-13 14:29:40 -0500

Seen: 55 times

Last updated: Dec 13 '16