Ask Your Question
0

Password change not working from puppet master to puppet agent [closed]

asked 2016-12-14 23:02:35 -0500

vidyasagar.reddy66@gmail.com gravatar image

I have written a site.pp to change a password from the puppet master. Below is the site.pp. It is changing the password on agent host idrac-h868gm1, but when I try to login with the changed password (In this case devuser888) it is not working.

I used single and double quotes but it still does not work. I manually changed the password to devuser888 and it is working.

 node default {
 class { 'ntp':
servers => ['ntp1','ntp2']
}
 include ntp
 }
  node /^(prod|dev)\d+$/ {
  include mounts
  include nis
  }
 node idrac-h868gm1 {
 user { 'dev':
 ensure   => present,
 password => "devuser888"
 }

}

Puppet server version: 2.7.1 (open source)
Puppet agent version: 4.8.0
Puppet agent OS: RHEL7.2

Below is the debug logs from puppet agent link

https://chelsious-my.sharepoint.com/p...asicdesignerscom/_layouts/15/guestaccess.aspx?guestaccesstoken=GaTobTW0sbrzL4u3oWvIZQVdjHkTGc2g1YUapTJhpAw%3d&docid=1f22eb1f7c8d54d61b5ce74553e38a694&rev=1

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Kai Burghardt
close date 2016-12-16 14:05:26.102625

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-12-15 03:16:51 -0500

lupin gravatar image

The value of password parameter is the encrypted password of your OS. ie, on RHEL 7 the value that you can get on /etc/shadow usually start with $ character.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-14 23:02:35 -0500

Seen: 43 times

Last updated: Dec 15 '16