Ask Your Question
0

I am getting below error while installing rtyler/jenkins. Please help me to get rid of this problem.

asked 2017-01-09 04:18:10 -0500

U D MISHRA gravatar image

updated 2017-01-09 13:24:27 -0500

DarylW gravatar image

Error Output

[root@agent ~]# puppet agent --test
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching catalog for agent.example.com
Info: Applying configuration version '1483954140'
Error: Could not find command 'jar'
Error: /Stage[main]/Jenkins::Cli/Exec[jenkins-cli]/returns: change from notrun to 0 failed: Could not find command 'jar'
Notice: /Stage[main]/Jenkins::Cli/File[/usr/lib/jenkins/jenkins-cli.jar]: Dependency Exec[jenkins-cli] has failures: true
Warning: /Stage[main]/Jenkins::Cli/File[/usr/lib/jenkins/jenkins-cli.jar]: Skipping because of failed dependencies
Notice: /Stage[main]/Jenkins::Cli/Exec[safe-restart-jenkins]: Dependency Exec[jenkins-cli] has failures: true
Warning: /Stage[main]/Jenkins::Cli/Exec[safe-restart-jenkins]: Skipping because of failed dependencies
Notice: /Stage[main]/Jenkins::Cli_helper/File[/usr/lib/jenkins/puppet_helper.groovy]: Dependency Exec[jenkins-cli] has failures: true
Warning: /Stage[main]/Jenkins::Cli_helper/File[/usr/lib/jenkins/puppet_helper.groovy]: Skipping because of failed dependencies
Notice: /Stage[main]/Jenkins/Anchor[jenkins::end]: Dependency Exec[jenkins-cli] has failures: true
Warning: /Stage[main]/Jenkins/Anchor[jenkins::end]: Skipping because of failed dependencies
Notice: Finished catalog run in 0.92 seconds
edit retag flag offensive close merge delete

Comments

it looks like you don't have a jdk installed/configured correctly. try `which java` `which javac` `which jar`. If you don't find all three of them, you may be misconfigured

DarylW gravatar imageDarylW ( 2017-01-09 13:26:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-14 02:07:15 -0500

stivesso gravatar image

Hello Mishra,

Make sure that you have installed all the module's dependencies, especially puppetlabs/java (>= 1.0.1 < 2.0.0) (or have Java installed...)

check here (see picture below)

puppetlabs/stdlib (>= 4.6.0 < 5.0.0)
puppetlabs/apt (>= 0.0.3 < 3.0.0)
puppetlabs/java (>= 1.0.1 < 2.0.0)
darin/zypprepo (>= 1.0.1 < 2.0.0)
puppet/archive (>= 0.4.8)

image description

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-01-09 04:18:10 -0500

Seen: 57 times

Last updated: Jan 14