Ask Your Question

Error: Could not request certificate: getaddrinfo: No such host is known

asked 2013-09-09 16:18:12 -0600

oskaremil gravatar image

updated 2013-09-10 10:08:14 -0600

I get this error on a new install of Puppet Enterprise Agent on a Windows Server 2012.

Puppetmaster and two Windows Puppet Enterprise nodes are on the same subnet. DNS is managed by Active Directory and both nodes are members of the domain.

Puppetmaster hostname is puppet. Both nodes can find the host, both by puppet and puppet.domain.local, there is a static host entry in AD DNS pointing to puppet.

puppet does not have any firewall enabled.

  • Node1, a Windows Server 2008, I ran the Puppet Enterprise installer, accepted the default hostname puppet for the puppetmaster and few ...

edit retag flag offensive close merge delete



and does `nslookup puppet` on your second node returns the ip of your puppetmaster then?

Stefan gravatar imageStefan ( 2013-09-09 16:22:39 -0600 )edit

Yes. nslookup finds puppet as puppet.domain.local and the correct ip address.

oskaremil gravatar imageoskaremil ( 2013-09-10 01:50:35 -0600 )edit

I suppose you can ping master. what is the content of your puppet.conf on a agent?

jaksky gravatar imagejaksky ( 2013-09-10 06:24:23 -0600 )edit

Which leads me to the next question; If I search for puppet.conf on the agent I find 10-15 files in different directories. Which one does the agent use, in ...(more)

oskaremil gravatar imageoskaremil ( 2013-09-10 07:18:09 -0600 )edit

Puppet Enterprise Installer does not update puppet.conf if it already exists. I reinstalled Puppet Enterprise and thought the correct hostname from the installer would be updated in puppet.conf.

oskaremil gravatar imageoskaremil ( 2013-09-13 01:21:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-09-13 01:19:36 -0600

oskaremil gravatar image

Oh... puppet.conf is not updated on a new installation if it already exists ? This explains it. puppet.conf had an invalid hostname as server, I though reinstalling updated that value.

edit flag offensive delete link more

answered 2013-09-10 09:41:49 -0600 gravatar image

i checked your output information from puppet agent -t --debug --verbose, there is no 'No such host is known', and the last line is 'Exiting; failed to retrieve certificate and waitforcert is disabled', it means your agent certificate is generated, uploaded to master and the master not signed it till now.

you should go to puppet master, use 'puppet cert list' command to check unsigned host and sign it.

edit flag offensive delete link more


Error messages are piped to stderr instead of stdout so the error message was not included in the file I copied the debug output from.

oskaremil gravatar imageoskaremil ( 2013-09-10 10:09:30 -0600 )edit

check puppet.conf ensure server is configured correctly or not configured. or just run puppet agent -t --server puppet and paste all output info you get. gravatar ( 2013-09-10 10:16:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-09-09 16:18:12 -0600

Seen: 40,333 times

Last updated: Sep 13 '13