puppet master can't work with passenger + nginx

asked 2017-01-18 23:36:27 -0500

hi:

I install puppet and passenger by gem,after that I install nginx by passenger-nginx-install-module,when I start it and exec puppet agent -t in client, It turn out eror follow this.how can I fix it.


  • [ 2017-01-19 13:21:06.1668 1313/7f27e75fe700 age/Cor/Con/CheckoutSession.cpp:277 ]: [Client 7-3] Cannot checkout session because a spawning error occurred. The identifier of the error is 5a6b39de. Please see earlier logs for details about the error. App 19817 stdout: App 19817 stdout:
  • [ 2017-01-19 13:21:08.4436 1313/7f282014a700 age/Cor/App/Implementation.cpp:304 ]: Could not spawn process for application /etc/puppet/rack: An error occurred while starting up the preloader.
  • Error ID: b6d50f76
    • Error details saved to: /tmp/passenger-error-sLemKg.html
    • Message from application: exit (SystemExit)
    • /usr/local/rvm/gems/ruby-2.2.6/gems/puppet-4.8.1/lib/puppet/util.rb:554:in 'exit'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/puppet-4.8.1/lib/puppet/util.rb:554:in 'rescue in exitonfail'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/puppet-4.8.1/lib/puppet/util.rb:540:in 'exitonfail'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/puppet-4.8.1/lib/puppet/application.rb:341:in 'run'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/puppet-4.8.1/lib/puppet/util/command_line.rb:132:in 'run'
  • /usr/local/rvm/gems/ruby-2.2.6/gems/puppet-4.8.1/lib/puppet/util/commandline.rb:72:in 'execute'
    • config.ru:44:in 'block in <main>'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/rack-2.0.1/lib/rack/builder.rb:55:in 'instanceeval'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/rack-2.0.1/lib/rack/builder.rb:55:in 'initialize' config.ru:1:in 'new' config.ru:1:in '<main>'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/passenger-5.0.22/src/helper-scripts/rack-preloader.rb:110:in 'eval'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/passenger-5.0.22/src/helper-scripts/rack-preloader.rb:110:in 'preload_app'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/passenger-5.0.22/src/helper-scripts/rack-preloader.rb:156:in '<module:app>'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/passenger-5.0.22/src/helper-scripts/rack-preloader.rb:30:in '<module:phusionpassenger>'
    • /usr/local/rvm/gems/ruby-2.2.6/gems/passenger-5.0.22/src/helper-scripts/rack-preloader.rb:29:in '<main>'

edit retag flag offensive close merge delete