How to add parameters for graphite class on the Learning VM so quotes do not appear in PE Console as part of Quest 4

asked 2017-02-28 04:24:31 -0600

I am very new to puppet, so I expect i have done something obviously silly. I have recently downloaded the learning vm (2016.5.1) and imported into Virtualbox. I have completed the initial 3 quests, but am struggling with X Task 4: Trigger a puppet agent run to install and configure Graphite I followed the doc, and added the node name, selected the certname OK, then went to add the parameters for graphite class as in

  • grwebserver = none
  • grdjangopkg = django
  • grdjangoprovider = pip
  • grdjangover = "1.5"

I'm not sure if this is the issue, but in the PE console, once i have added these they all have "" whereas the doc only has the ver parameter as "1.5"

  • grdjangopkg ="django"
  • grdjangoprovider ="pip"
  • grdjangover ="1.5"
  • grwebserver ="none" Please advise? This is an offline VM with no direct internet access.
    When I then run puppet agent --test I get errors Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Failed to execute '/pdb/cmd/v1?checksum=ed94f31fa948e2651706e81e4c6eb2c8ff088f58&version=9&certname=learning.puppetlabs.vm&command=replacecatalog' on at least 1 of the following 'serverurls': https://learning.puppetlabs.vm:8081

Errors around Graphite install and Dependency Package failures

edit retag flag offensive close merge delete