Ask Your Question
0

[Error]: Failed to apply catalog: Connection refused - connect(2) for "<domain-name>" port 4433 [closed]

asked 2017-03-20 13:09:19 -0500

manikantasaid gravatar image

I'm trying to install latest version of puppet from tar ball on an EC2 instance. The steps I followed are:

-Launch a RHEL7 instance. Assign an Elastic IP address. Create a record set on Route 53 using the elastic IP.

-The security group allows all incoming traffic to the instance. No firewalld/iptables installed.

-I'm able to access the Web UI on port 3000 for installation. After the installation proceeds for some time, The error shows up and the installation is aborted

Please help me understand what is causing this problem and help me solve it.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by manikantasaid
close date 2017-03-20 18:35:50.313479

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-20 18:31:04 -0500

manikantasaid gravatar image

updated 2017-03-20 18:37:06 -0500

All along the installation I was using a t2.micro with 1GB memory from free tier usage. But, when I used a medium instance with 4GB memory the installation went through with out any errors. But, the error "connection refused to port" did not make me think that it was a memory issue. I think that some service has to run on port 4433 for the installation to continue, since there is no memory available the corresponding service or process is not launched. Correct me if I'm wrong.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-03-20 13:07:19 -0500

Seen: 105 times

Last updated: Mar 20