no SLES on power agent?!

asked 2017-03-24 05:25:32 -0500

Jens Phlip. gravatar image

I installed Puppet Enterprise on some RedHat systems and it works well. Now I wanted to use puppet on my SLES 11 & 12 systems, too. As I tried to find the agent on the Puppet Master, I saw that there is no agent for SLES on power?! Is there no Puppet Enterprise agent for SLES on IBM Power systems? I also found, that there is a preinstalled Puppet agent on SLES, but it is the open source one and I didn´t get it to work with my Puppet Enterprise Master. Is it not possible or am I doing something wrong? I signed the certificate on the Puppet Master GUI, but the puppet run throws this error:


err: Could not retrieve catalog from remote server: Error 500 on SERVER: {"message":"Server Error: Could not intern from b64zlibyaml: No format match the given format name or mime-type (b64zlibyaml)","issuekind":"RUNTIMEERROR","stacktrace":["Warning: The 'stacktrace' property is deprecated and will be removed in a future version of Puppet. For security reasons, stacktraces are not returned with Puppet HTTP Error responses."]} warning: Not using cache on failed catalog err: Could not retrieve catalog; skipping run err: Could not send report: Error 500 on SERVER: {"message":"Server Error: YAML in network requests is not supported. See http://links.puppetlabs.com/deprecateyamlonnetwork","issuekind":"RUNTIME_ERROR","stacktrace":["Warning: The 'stacktrace' property is deprecated and will be removed in a future version of Puppet. For security reasons, stacktraces are not returned with Puppet HTTP Error responses."]}


Thanks in advance for any help!

edit retag flag offensive close merge delete