Ask Your Question
0

puppetdb not picking up the server_urls from config file

asked 2017-03-27 21:41:24 -0500

Hi,

In my config file I have server URL listed like this

  cat /etc/puppetlabs/puppet/puppetdb.conf
[main]
  server_urls = https://webserver:8081

but when I run the 'puppet agent --test' command its picking

'server_urls': https://puppetdb:8081

Where is piking up the wrong URL. I am getting below error.

# puppet agent --test
Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Error 500 on SERVER: Server Error: Could not retrieve facts for webserver: Failed to find facts from PuppetDB at puppet:8140: Failed to execute '/pdb/query/v4/nodes/webserver/facts' on at least 1 of the following 'server_urls': https://puppetdb:8081
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching facts for webserver
Info: 'replace_facts' command for webserver submitted to PuppetDB with UUID d90c18fd-28b9-496d-9084-a5fe352ad1a7
Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Failed to execute '/pdb/cmd/v1?checksum=fb53810f67e7f80f68d79ba917b9e4cd81e07a46&version=5&certname=webserver&command=replace_facts' on at least 1 of the following 'server_urls': https://puppetdb:8081
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-28 18:51:22 -0500

Based on puppet document https://docs.puppet.com/puppetdb/late...

Puppet by default use this URL. server_urls = https://puppetdb.example.com:8081

we can overwrite this value in /etc/puppetlabs/puppet/puppetdb.conf file.

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-27 21:41:24 -0500

Seen: 37 times

Last updated: Mar 28