remove lookup for puppet master in standalone mode

asked 2017-03-31 13:39:13 -0500

Hello !

I'm having the following issue : Puppet writes many logs in my /var/log/syslog saying :
Could not request certificate: getaddrinfo: Name or service not known

From what I understood this comes from puppet agent looking by default for the master server puppet.[my_domain].
My problem is that I'm running puppet in standalone mode, so I don't have a master server.

How can I stop the agent looking for a master server / stop it generating those logs ?

Many thanks.

edit retag flag offensive close merge delete

Comments

Set the server configuration to localhost?

Richard Berwald gravatar imageRichard Berwald ( 2017-04-02 07:40:26 -0500 )edit