What could cause "Caching connection for https://<puppetfqdn>:8140" to hang for 8+ minutes

asked 2017-04-03 11:26:53 -0600

mg.mackie gravatar image

updated 2017-04-03 16:05:38 -0600

DarylW gravatar image

I have a Windows Server 2012 R2 system where puppet runs were taking much longer than expected to complete. To troublshoot I ran

puppet agent -t --debug

piped to a file and timestamped using a vbs script. What I found was that although the run was a little slower than I would like, the real issue is here:

4/3/2017 12:03:57 PM - Debug: Failed to load library 'msgpack' for feature 'msgpack'

4/3/2017 12:03:57 PM - Debug: Puppet::Network::Format[msgpack]: feature msgpack is missing

4/3/2017 12:03:57 PM - Debug: file_metadata supports formats: pson yaml binary

4/3/2017 12:03:57 PM - Debug: Using cached connection for https://<redacted>:8140

4/3/2017 12:03:57 PM - Debug: Caching connection for https://<redacted>:8140

4/3/2017 12:11:16 PM - Debug: Failed to load library 'msgpack' for feature 'msgpack'

4/3/2017 12:11:16 PM - Debug: Puppet::Network::Format[msgpack]: feature msgpack is missing

4/3/2017 12:11:16 PM - Debug: file_metadata supports formats: pson yaml binary

4/3/2017 12:11:16 PM - Debug: Closing connection for https://<redacted>:8140

4/3/2017 12:11:16 PM - Debug: Creating new connection for https://<redacted>:8140

4/3/2017 12:11:16 PM - Debug: Starting connection for https://<redacted>:8140

4/3/2017 12:11:19 PM - Debug: Caching connection for https://<redacted>:8140

This happens right before applying the first class in the catalog. These exact steps seem to happen without that delay at other points in the run. I'm at a loss as to what could be happening during that time.

edit retag flag offensive close merge delete