Ask Your Question
0

"Error: invalid distance too far back" on windows

asked 2013-09-13 05:23:39 -0500

Wolfwood gravatar image

I'm trying to run the "librarian-puppet install" command under windows 7 in a "Start Command Prompt with Puppet" window (which is run as Administrator), only to get the following error:

D:\webdev\test\vagrant>*librarian-puppet install --verbose*
[Librarian] Ruby Version: 1.9.3
[Librarian] Ruby Platform: i386-mingw32
[Librarian] Rubygems Version: 1.8.24
[Librarian] Librarian Version: 0.0.24
[Librarian] Librarian Adapter: puppet
[Librarian] Project: D:\webdev\test\vagrant
[Librarian] Specfile: Puppetfile
[Librarian] Lockfile: Puppetfile.lock
[Librarian] Git: d:/java/Git/cmd/git.EXE
Error: invalid distance too far back
Error: Try 'puppet help module install' for usage

The ... (more)

edit retag flag offensive close merge delete

Comments

Can you provide a copy of the config files for your librarian-puppet setup?

llowder gravatar imagellowder ( 2013-12-10 10:24:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-03 16:56:41 -0500

This could be an issue with PMT or not having the correct certificates installed. Can you determine if you can install modules manually using puppet module install modulenamespace/modulename first? If that is working, then we can move forward to try to figure out what might be wrong in librarian.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-13 05:23:39 -0500

Seen: 569 times

Last updated: Oct 03 '14