Ask Your Question
0

No version of 'puppet-autofs' can satisfy all dependencies

asked 2017-04-21 22:05:18 -0600

tylerecouture gravatar image

updated 2017-04-21 22:51:22 -0600

I'm trying to install the approved autofs module: puppet-autofs But I get this error:

root@puppet:/etc/puppetlabs/code/environments# puppet module install puppet-autofs --version 3.0.1 --environment production
Notice: Preparing to install into /etc/puppetlabs/code/environments/production/modules ...
Notice: Downloading from https://forgeapi.puppet.com ...
Error: Could not install module 'puppet-autofs' (???)
  No version of 'puppet-autofs' can satisfy all dependencies
    Use `puppet module install --ignore-dependencies` to install only this module

Both of the requirements, stdlib and concat are installed:

/opt/puppetlabs/puppet/modules
├── puppetlabs-apt (v2.2.2)
├── puppetlabs-concat (v1.2.5)
├── puppetlabs-reboot (v1.2.1)
├── puppetlabs-stdlib (v4.16.0)

AutoFS requires concat >= 2.0.0. However, when I try to update concat, I get:

Notice: Downloading from https://forgeapi.puppet.com ...
Error: Could not upgrade module 'puppetlabs-concat' (v1.2.5 -> latest)
  There are 4 newer versions
    No combination of dependency upgrades would satisfy all dependencies
    Dependencies will not be automatically upgraded across major versions
    Upgrading one or more of these modules may permit the upgrade to succeed:
    - puppetlabs-stdlib

But stdlib is already up to date, and a version that concat says it supports!

I tried updateing concat to 2.1.0, but get this.

Error: Could not upgrade module 'puppetlabs-concat' (v1.2.5 -> v2.1.0)
  No version of 'puppetlabs-concat' can satisfy all dependencies
    Use `puppet module upgrade --ignore-dependencies` to upgrade only this module

I have no idea what other module might depend on it. Is there a way to view a dependanciy tree of all installe dmodules or something like that?

Any ideas how I can troubleshoot this?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-11-01 14:52:55 -0600

The key line is "Dependencies will not be automatically upgraded across major versions", (see http://semver.org/) which is triggered by going from major 1 to major 3.

Try upgrading to a version 2 release first, which has helped me upgrade modules. Check the Changelog tag in the modules forge page to review changes.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-21 22:05:18 -0600

Seen: 1,850 times

Last updated: Apr 21