Ask Your Question
0

Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Syntax error at '8' at

asked 2017-05-01 15:35:35 -0500

gangadhar gravatar image

updated 2017-05-03 12:09:46 -0500

DarylW gravatar image

class entapps::role::teamcity {

    dsc_package { 'mysqlconnector':
      dsc_ensure    => 'Present',
      dsc_name      => 'MySQL Connector Net 6.9.9',
      dsc_productid => 'E09F82E9-3EB3-4725-BDC8-3C77F83E262C',
      dsc_path      => 'D:\\DSCPackages\\mysql-connector-net-6.9.9.msi',
    }

    if $::hostname =~ /^erp-(udc|aws)-build(07|08)/ {
      package { 'tightvnc':
        ensure    => 2.8.8,
        provider  => 'chocolatey',
    }
  }

When I run pupet agent -t I have received the following error

"Error: Facter: error while resolving custom facts in C:/ProgramData/PuppetLabs/puppet/cache/lib\facter\salts.rb: undefined method `split' for nil:NilClass
13:18:42            Error: Facter: error while resolving custom facts in C:/ProgramData/PuppetLabs/puppet/cache/lib/facter\salts.rb: undefined method `split' for nil:NilClass
13:18:44            Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Syntax error at '8' at /etc/puppetlabs/code/environments/production/teamcity.pp:23:26 on node ***-**-***.****

I am unable to figure out the issue within the code. Can anyone here provide workaround to resolve this issue.

Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-05-01 21:08:46 -0500

smarlow gravatar image

I believe that your problem is

ensure => 2.8.8,

since Puppet doesn't know how to interpret 2.8.8. Enclosing it in quotes should do the trick. For example:

ensure => '2.8.8',
edit flag offensive delete link more

Comments

1

Thanks @smarlow, I changed the syntax and read the actual chocolatey module doc in PuppetForge.

gangadhar gravatar imagegangadhar ( 2017-05-02 12:12:41 -0500 )edit
0

answered 2017-05-02 23:30:28 -0500

gangadhar gravatar image

Thanks. I also forgot to add "}" at the end

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-01 15:35:35 -0500

Seen: 251 times

Last updated: May 03