Puppet Agent Error retrieving catalog

asked 2017-05-03 23:55:42 -0600

Negwoh gravatar image

Hi Guys,

I have a really simple setup with 1 puppet server and a couple of dev/test boxes. Up to this point I have only used/written my own classes and manifests, and everything has been going swimmingly. I have now added a module to install ssh (sudo puppet module install saz-ssh) and added this straight into the site.pp under node 'servername' { include ssh } but I now get the error: "Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Evaluation. Error While evaluating a Resource Statement, HTTP request path is empty at /etc/puppetlabs/code/environments/production/manifests/site.pp:21:2 on node servername."

NB: line 21:2 is the exact place I added my new node definition

I have tried other modules (sensu) and had the same exact error, although if I remove everything and leave my own modules in, everything works fine. Any ideas, I'm hoping I am just a muppet and did something wrong?

edit retag flag offensive close merge delete


Two thoughts... 1. do the files for the module exist where you expect them? (under the result of sudo puppet config print modulepath). 2. If they do, are they in a form that the user that is running puppet can read them? try `chmod a+rX $(sudo puppet config print modulepath)` to open up read perms

DarylW gravatar imageDarylW ( 2017-05-04 10:17:59 -0600 )edit

Thanks for the quick reply, I had thought it might be permissions too so did a chown puppet:puppet on the modules folder (as alot were owned by root) and a chmod 777 just for kicks but this did not resolve the issue. Also my modules patch returns 4 directories, one of which is the path expected

Negwoh gravatar imageNegwoh ( 2017-05-04 17:05:11 -0600 )edit

Can you tell us the value of your modulepath and the path where saz-ssh got installed?

smarlow gravatar imagesmarlow ( 2017-05-04 19:27:25 -0600 )edit

$ sudo /opt/puppetlabs/bin/puppet config print modulepath /etc/puppetlabs/code/environments/production/modules:/etc/puppetlabs/code/environments/common:/etc/puppetlabs/code/modules:/opt/puppetlabs/puppet/modules

Negwoh gravatar imageNegwoh ( 2017-05-04 19:31:52 -0600 )edit

$ sudo /opt/puppetlabs/bin/puppet module list /etc/puppetlabs/code/environments/production/modules ... ├── saz-ssh (v3.0.1) ... /etc/puppetlabs/code/environments/common (no modules installed) /etc/puppetlabs/code/modules (no modules installed) /opt/puppetlabs/puppet/modules ... └── saz-ssh (v3.0.1)

Negwoh gravatar imageNegwoh ( 2017-05-04 19:32:59 -0600 )edit