Ask Your Question

Installing third party module

asked 2013-09-15 13:11:04 -0600

moby gravatar image

updated 2013-09-17 09:50:35 -0600

golja gravatar image

I'm trying to install the module located at What I don't seem to understand is where to place

class mongodb {
  enable_10gen => true,

in their Usage and installation instructions.

I've already cloned the repo and put it in /etc/puppet/modules/mongodb.

If I put that in my main site.pp file, I get a syntax error:

Could not parse for environment production: Syntax error at '=>'; expected '}' at /etc/puppet/manifests/site.pp:8

Line 8 is in reference to the enable_10gen line.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-09-15 20:53:22 -0600

golja gravatar image

updated 2013-09-15 20:57:31 -0600

I think that the documentation is wrong, because you are not allowed to initialise an class in that way.

So try

class {'mongodb': enable_10gen => true, }

or if you are happy with the default parameters

inlcude mongodb

However form a quick look this module looks quite old and simple ,but 10gen/mongodb is changing all the time so maybe you should try one module which is more up to date.

Look at the github thread here about the syntax error:

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-09-15 13:11:04 -0600

Seen: 430 times

Last updated: Sep 15 '13