Ask Your Question
0

override an resource

asked 2017-05-17 19:59:13 -0500

minimike gravatar image

updated 2017-05-17 20:21:31 -0500

smarlow gravatar image

Hi there,

How could I overwrite these courios resource-statement from openstack-neutron in authtoken.pp. Here the class directly from github: link text

I've tried it by calling the class

class profiles::neutron {

class { '::neutron':
  core_plugin => 'ml2',
  allow_overlapping_ips => true,
   service_plugins =>  ['router'],
   auth_strategy => 'keystone',
   dns_domain => 'webterrorist.local.',
   default_transport_url => 'rabbit://openstack:askgoogle@192.168.253.10',
   rabbit_password       => 'askgoogle',
   rabbit_user           => 'openstack',
   rabbit_host           => '192.168.253.10',
 }

class { '::neutron::keystone::authtoken':
   user_domain_name               => 'default',
   project_domain_name            => 'default',
   username                       => 'neutron',
   password                       => 'askgoogle',
   project_name                   => 'service',
   auth_url                       => 'http://192.168.253.10:35357',
   auth_uri                       => 'http://192.168.253.10:5000',
   auth_type                      => 'password',
   project_domain_name            => 'default',
   memcached_servers              => '127.0.0.1:11211',
   manage_memcache_package        => false,
   region_name                    => 'ImperiumAlpha',
 }

 class { '::neutron::agents::ml2::ovs':
   local_ip     => "${::ipaddress}",
   tunnel_types => ['vxlan']
 }
}

But get these

Error while evaluating a Resource Statement, Keystone::Resource::Authtoken[neutron_config]: has no parameter named 'manage_memcache_package' at /usr/local/etc/puppet/environments/staging/modules/neutron/manifests/keystone/authtoken.pp:246

Keystone::Resource::Authtoken[neutron_config] is not a class but part of the class neutron::keystone::authtoken How could I call it to overide the settings in these Module?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-05-17 20:32:19 -0500

smarlow gravatar image

So basically Neutron::Keystone::Authtoken is declaring Keystone::Resource::Authtoken with an invalid parameter.

Looking at the current version of Keystone::Resource::Authtoken there is indeed a manage_memcache_package parameter in it, and that parameter was added 9 months ago in version 9.5.0 of the openstack/keystone Puppet module.

It is very likely then that you do not need to override the resources at all. Instead you should ensure that both openstack/neutron and openstack/keystone are up-to-date and using compatible versions, i.e. ensure that openstack/keystone is at least version 9.5.0 if not the latest version 11.0.0 .

edit flag offensive delete link more
0

answered 2017-05-19 18:17:34 -0500

minimike gravatar image

thank you for your hint with the versions. I have changed it in my Puppetfile abd checked them out again. Now its working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-17 19:59:13 -0500

Seen: 40 times

Last updated: 2 days ago