Ask Your Question
1

Error 500: pe_packages after 2017.2 install

asked 2017-05-22 10:27:26 -0500

chriswilkes33 gravatar image

updated 2017-05-23 15:35:14 -0500

Last week I tried to install PE 2017.2 over our working 2016.5 instance. I copied the tarball to our server, unpacked it, and ran puppet-enterprise-installer script. The install seemed to run without error and it told me to finish the install I should run puupet agent -t on the server. This is a monolithic install. The puppet run returns error 500 saying that is cannot get metadata for puppet:///pe_packages/2017.2.1/el-7_x86_64-1.10.1.

This directory does not exist but I do have a similar directory at /opt/puppetlabs/server/data/packages/public that contains all of the packages. Also /etc/puppetlabs/puppet/fileserver.conf has a [pe_packages] section with path set to /opt/puppetlabs/server/data/packages/public and allow *

Is it possible I have bad permissions or something on the /opt/puppetlabs/server/data/packages/public folders or is there somewhere else I can look. I have tried reinstalling several times with the same issue, I have also tried reinstalling using a new pe.conf file, the one I am using though only has password, dnsaltname, and hostname settings set.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-06-07 08:22:47 -0500

chriswilkes33 gravatar image

updated 2017-06-07 08:23:08 -0500

I thought I would answer that eventually the issue was worked out by changing permissions on fileserver.conf, It was not properly readable.

edit flag offensive delete link more
0

answered 2017-05-23 11:46:06 -0500

smarlow gravatar image

My reference 2017.2.1 install has a pe_packages mount point in /etc/puppetlabs/puppet/fileserver.conf, so I suspect that the naming of the mount point may have changed between versions.

If you have the directory /opt/puppetlabs/server/data/packages/public/2017.2.1/el-7_x86_64-1.10.1 on your system then this should be a simple matter. Just copy the stanza for [pe_puppet] in the file, rename it to [pe_packages], and restart the pe-puppetserver service.

This will expose the same files under the name that it expects and should allow the installation to continue.

edit flag offensive delete link more

Comments

I looked in fileserver.conf and it had sections for [pe_packages] and [pe_modules]. I added one for [pe_puppet] on a whim and made it match the [pe_packages] section but that also failed. for reference that file looks like:

chriswilkes33 gravatar imagechriswilkes33 ( 2017-05-23 13:10:59 -0500 )edit

[code] [pe_packages] path /opt/puppetlabs/server/data/packages/public allow * [pe_modules] path /opt/puppetlabs/server/share/installer/modules allow * [pe_puppet] path /opt/puppetlabs/server/data/packages/public allow * [/code]

chriswilkes33 gravatar imagechriswilkes33 ( 2017-05-23 13:12:33 -0500 )edit

The 2017.5.2/el-7_x86_64-1.10.1 directories are both owned by root:root which is different than the older directories in that pe_packages path, they are all owned by pe-puppet:pe-puppet, permissions are all 0644 on files and 0755 on directories though. If I change it, the installer changes it back.

chriswilkes33 gravatar imagechriswilkes33 ( 2017-05-23 13:13:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-05-22 10:27:26 -0500

Seen: 76 times

Last updated: Jun 07