Unable to start Puppet Enterprise Puppetserver

asked 2017-06-08 08:47:24 -0600

newcomer gravatar image

updated 2017-06-09 08:02:46 -0600

Hi Guys,

I download puppet enterprise VM and was trying to start puppetserver and I get the error below:`Logfile name=puppetserver.log

2017-06-08 06:27:08,286 INFO  [async-dispatch-2] [p.e.s.m.master-service] Puppet Server has successfully started and is now ready to handle requests
2017-06-08 06:27:08,288 INFO  [async-dispatch-2] [p.e.s.l.pe-legacy-routes-service] The legacy routing service has successfully started and is now ready to handle requests
2017-06-08 06:27:08,294 INFO  [async-dispatch-2] [p.e.s.a.analytics-service] Puppet Server Analytics has successfully started and will run in the background
2017-06-08 06:27:09,644 INFO  [pool-2-thread-1] [p.d.version-check] Newer version 2017.2.1 is available! Visit http://links.puppet.com/enterpriseupgrade for details.
2017-06-08 06:27:09,680 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:8081/metrics/v1/mbeans/puppetlabs.puppetdb.population:name=num-nodes: java.net.ConnectException: Connection refused
2017-06-08 06:27:09,693 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:8081/pdb/query/v4/facts: java.net.ConnectException: Connection refused
2017-06-08 06:27:09,708 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:8081/pdb/query/v4/facts: java.net.ConnectException: Connection refused
2017-06-08 06:27:09,924 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:8081/pdb/query/v4/facts: java.net.ConnectException: Connection refused
2017-06-08 06:27:10,007 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:4433/metrics/v1/mbeans/puppetlabs.classifier%3Aname%3Dpuppetlabs.puppetlabs.classifier.total-groups: java.net.ConnectException: Connection refused
2017-06-08 06:27:10,024 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:8143/metrics/v1/mbeans/puppetlabs.orchestrator%3Aname%3Dpuppetlabs.localhost.job-nodes.histogram: java.net.ConnectException: Connection refused
2017-06-08 06:27:10,534 WARN  [pool-2-thread-1] [p.e.s.a.analytics-utils] Failed to reach server https://master.puppetlabs.vm:8143/metrics/v1/mbeans/puppetlabs.orchestrator%3Aname%3Dpuppetlabs.localhost.created-job.counter: java.net.ConnectException: Connection refused
2017-06-08 06:27:10,859 WARN  [clojure-agent-send-pool-0] [puppetserver] Puppet Support for ruby version 1.9.3 is deprecated and will be removed in a future release. See https://docs.puppet.com/puppet/latest/system_requirements.html#ruby for a list of supported ruby versions.
   (at /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:167:in `Puppet')
2017-06-08 06:27:10,886 INFO  [clojure-agent-send-pool-0] [puppetserver] Puppet Puppet settings initialized; run mode: master
2017-06-08 06:27:11,406 INFO  [clojure-agent-send-pool-0] [p.s.j.i.jruby-agents] Finished creating JRubyInstance 2 of 3
2017-06-08 06:27:11,406 INFO  [clojure-agent-send-pool-0] [p.s.j.i.jruby-internal] Creating JRubyInstance with id 3.
2017-06-08 06:27:14,406 WARN  [clojure-agent-send-pool-0] [puppetserver] Puppet Support for ruby version 1.9.3 is deprecated and will be removed in a future release. See https://docs.puppet.com/puppet/latest/system_requirements.html#ruby for a list of supported ...
(more)
edit retag flag offensive close merge delete