Ask Your Question
0

change master port in Puppet Enterprise 3.X

asked 2013-09-17 04:13:03 -0500

Anandu gravatar image

updated 2013-09-17 04:14:42 -0500

Hi All,

There is a option to change master port from default 8140 in Puppet Master Opensource edition. $confdir/puppet.conf can be set "masterport = <%= @master_port %>". But this setting is not valid in Puppet Master Enterprise edition.

I have tried to change listen port in vim "/etc/puppetlabs/httpd/conf.d/puppetmaster.conf". But on my puppet agent following error message comes after execution of "puppet agent -t".

  • notice: XXXX.node.name (osfamily = RedHat) is not a Puppet Enterprise agent. It will not appear when using the mco command-line tool or from within Live Management in the Puppet Enterprise Console ...
(more)
edit retag flag offensive close merge delete

Comments

After changing configuration run "puppet master" command to reflect the changes and then "puppet --genconfig | grep masterport" to see whether the changes has been updated or not. Because it may ...(more)

Sneha More gravatar imageSneha More ( 2013-09-18 07:34:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-18 06:17:12 -0500

Anandu gravatar image

Seems like change in $confdir/puppet.conf and listen port in vim "/etc/puppetlabs/httpd/conf.d/puppetmaster.conf" both required to change master port in Puppet Master Enterprise edition.

The error message is a notice as I am using OpenSource Puppet client to connect the Puppet Master Enterprise edition.

Any other views are appreciated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-17 04:13:03 -0500

Seen: 1,377 times

Last updated: Sep 18 '13