Passenger problem

asked 2017-06-09 14:43:08 -0600

Alireza Nasri gravatar image

Hello I've installed puppet server but I couldn't implement apache with passenger along together. apache works fine but I think there is something wrong with passenger. Also I have no access to http://192.168.1.1:8140, pretty sure port is open I checked it via telnet however puppet works fine with puppserver.

Error ID: 4af67d38 Error details saved to: /tmp/passenger-error-pUovSo.html Message from application: no such file to load -- rack (LoadError) /usr/lib/ruby/siteruby/1.8/rubygems/coreext/kernelrequire.rb:55:in gem_original_require' /usr/lib/ruby/site_ruby/1.8/rubygems/core_ext/kernel_require.rb:55:inrequire' /usr/local/rvm/gems/ruby-2.2.2/gems/passenger-5.1.4/src/rubysupportlib/phusionpassenger/loadersharedhelpers.rb:430:in activate_gem' /usr/local/rvm/gems/ruby-2.2.2/gems/passenger-5.1.4/src/helper-scripts/rack-preloader.rb:102:inpreloadapp' /usr/local/rvm/gems/ruby-2.2.2/gems/passenger-5.1.4/src/helper-scripts/rack-preloader.rb:156

edit retag flag offensive close merge delete