Ask Your Question
0

unable to connect agent to puppet master

asked 2017-06-12 04:05:34 -0500

kanchan gravatar image

using command: puppet agent -t error is: Error: Could not request certificate: Connection refused - connect(2) Exiting; failed to retrieve certificate and waitforcert is disabled

in agent server,i can see /etc/hosts contains puppet master hostname and i.p 177.177.177.10 master pinocchio.dev.mobistar.be pinocchio.puppetlabs.lro

edit retag flag offensive close merge delete

Comments

Do you see the required ports are in listening mode on puppet master? Also, do you have entry of your master's IP in puppet.conf (on agent node)?

rajeevsharma gravatar imagerajeevsharma ( 2017-06-14 01:07:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-08-21 05:17:22 -0500

Hi, Try to ping 177.177.177.10 on the agent. If it's working fine then Try to recreate the cert for both Master and Agnet.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-12 04:05:34 -0500

Seen: 156 times

Last updated: Aug 21