Ask Your Question
0

puppet-glance gets error with puppet agent -t but no error with puppet apply?

asked 2017-06-19 12:42:55 -0500

Red Cricket gravatar image

updated 2017-06-19 18:03:50 -0500

Hi,

I have run into a strange problem. I have been experimenting with moving from PE to open source puppet for building out an Mitaka OpenStack cloud. RIght now I have a puppet master, most-ppt-01, and two controller nodes: most-mgmt-01 and most-mgmt-02. The first controller node, most-mgmt-01 is associated with the puppet master and most-mgmt-02 is masterless.

When I run puppet agent -t on most-mgmt-01 I get this error:

# puppet agent -t
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Evaluation Error: Unknown variable: 'default_store_real'. at /etc/puppetlabs/code/environments/production/modules/glance/manifests/api.pp:389:9 on node most-mgmt-01
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

But when I run puppet apply -e 'include controller' on most-mgmt-01 I only get a warning:

Warning: Unknown variable: 'default_store_real'. at /etc/puppetlabs/code/environments/production/modules/glance/manifests/api.pp:389:9

I am using the stable/mitaka branch from here: https://github.com/openstack/puppet-glance/tree/stable/mitaka. And I am running puppet version:

# puppet -V
4.10.2

On all nodes/hosts. Also this code did not throw in error or report a warning when I was using PE 2016.2.

You can see the glance::api code here: https://github.com/openstack/puppet-g...

UPDATE: I have tried setting the strict and strict_variables configuration items on my master and agent like so:

# puppet config set strict off
# puppet config set strict_variables false
# puppet config print | grep strict
strict = off
strict_environment_mode = false
strict_hostname_checking = false
strict_variables = false

Yet I still get the same error when I execute puppet agent -t on my node.

edit retag flag offensive close merge delete

Comments

Red Cricket gravatar imageRed Cricket ( 2017-06-19 15:50:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-19 21:07:25 -0500

Red Cricket gravatar image

Here's what my puppet has confiugured:

# puppet config print | grep strict
strict = warning
strict_environment_mode = false
strict_hostname_checking = false
strict_variables = true

If I change it like so (as per https://docs.puppet.com/puppet/latest...):

# puppet config set strict_variables false
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-19 12:42:55 -0500

Seen: 20 times

Last updated: Jun 19