Ask Your Question
0

How to install puppet agent 3.8.x on Ubuntu 17.04

asked 2017-06-20 22:28:21 -0600

My puppet master server is 3.8.x , but the default puppet version is 4.8 on Ubuntu 17.04, the certificate can't be support. Also server version can't upgrade, so how to install puppet agent 3.8.x on Ubuntu 17.04? too many dependence failed when I install manual.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-21 08:56:03 -0600

DarylW gravatar image

Puppet 3 is End Of Life (EOL). https://rnelson0.com/2016/10/25/puppet-3-end-of-life-12312016/ Official EoL announcement on the puppet Google Group

The only method that would work, as far as I know, would be a gem based install, but since puppet 3.x doesn't use the 'All in One Packaging' like puppet 4.x does, it would be dependant on your system ruby... you would have to install an older version of ruby that is compatible with puppet.

Here are the docs on doing a gem based install... ( https://docs.puppet.com/puppet/3.8/in... )

I would HIGHLY recommend that you look into upgrading your puppet master (This is coming from someone who's former team is still on 3.x, and I know of people STILL on 2.x). If you are able to update your infrastructure to handle nodes with Ubuntu 17.04, then there should be no reason that you can't bring your master up to 4.x (with 5.x on the horizon). Official Upgrade Docs

edit flag offensive delete link more

Comments

1

Thanks @DarylW, I have fixed this issue by manual installing from Source https://downloads.puppetlabs.com/puppet/ and then fix the puppet.service, looks it can work well now.

spystar gravatar imagespystar ( 2017-06-22 04:44:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-20 22:28:21 -0600

Seen: 225 times

Last updated: Jun 21