Ask Your Question
0

No response for puppet cert list in puppet server

asked 2017-06-27 09:16:08 -0600

karthikeyanselvaraju@gmail.com gravatar image

updated 2017-06-27 09:17:21 -0600

I have setup the puppet server and puppet agent, both are active and running good. But certificates are not getting exchanged. When I try to list the certificates in puppet server, I am not getting any response. I checked SSL directory for certificates but there is no certificate exchange happened.

root@EMJUPuppetmaster:/etc/default# sudo systemctl status puppetserver ● puppetserver.service - puppetserver Service Loaded: loaded (/lib/systemd/system/puppetserver.service; disabled; vendor preset: enabled) Active: active (running) since Tue 2017-06-27 13:54:09 UTC; 18s ago Process: 7590 ExecStart=/opt/puppetlabs/server/apps/puppetserver/bin/puppetserver start (code=exited, status=0/SUCCESS) Main PID: 7601 (java) Tasks: 28 Memory: 1.2G CPU: 59.318s CGroup: /system.slice/puppetserver.service └─7601 /usr/bin/java -Xms3g -Xmx3g -XX:MaxPermSize=256m -Djava.security.egd=/dev/urandom -XX:OnOutOfMemoryError=ki

Jun 27 13:53:33 EMJUPuppetmaster systemd[1]: Starting puppetserver Service... Jun 27 13:53:33 EMJUPuppetmaster puppetserver[7590]: OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; supp Jun 27 13:54:09 EMJUPuppetmaster systemd[1]: Started puppetserver Service. lines 1-14/14 (END) root@EMJUPuppetmaster:/etc/default# sudo systemctl enable puppetserver Synchronizing state of puppetserver.service with SysV init with /lib/systemd/systemd-sysv-install... Executing /lib/systemd/systemd-sysv-install enable puppetserver root@EMJUPuppetmaster:/etc/default# sudo /opt/puppetlabs/bin/puppet cert list root@EMJUPuppetmaster:/etc/default# sudo /opt/puppetlabs/bin/puppet cert list root@EMJUPuppetmaster:/etc/default#

Puppet agent creating certificate and trying to exchange but getting below error during communication.

root@emjupuppetagent:/etc# sudo /opt/puppetlabs/bin/puppet agent --test Info: Creating a new SSL key for emjupuppetagent.1elecabews1e1icy5kmbz... Error: Could not request certificate: getaddrinfo: Name or service not known Exiting; failed to retrieve certificate and waitforcert is disabled root@emjupuppetagent:/etc#

Having the host file updated in puppet agent also. Can someone suggest a option to get rid of it. Facing this for the first time.

edit retag flag offensive close merge delete

Comments

Sounds like your dns server don't know about your puppet master. -> getaddrinfo: Name or service not known

Red Cricket gravatar imageRed Cricket ( 2017-06-27 22:39:39 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-06-27 23:33:07 -0600

joshc gravatar image

updated 2017-06-27 23:33:21 -0600

By default, agents attempt to connect to puppet, which isn't resolvable in your network. You'll want to set the server setting on each agent to your puppetserver's FQDN.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-27 09:16:08 -0600

Seen: 46 times

Last updated: Jun 27