Ask Your Question
0

Cannot 'replace facts' in puppetdb

asked 2013-09-18 12:31:06 -0600

updated 2013-09-19 03:53:28 -0600

I'm rebuilding a proof of concept silo for PE 3, but using a different domain than I had used before.

I get the following error in my puppet agent run:

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Failed to submit 'replace facts' command for ns1.**[current domain]** to PuppetDB at puppetdb.**[current domain]**:8081: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed: [unable to get local issuer certificate for /CN=puppetdb.**[old domain]**]
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

I ... (more)

edit retag flag offensive close merge delete

Comments

I just posted what is essentially an identical question. What I have found is that the puppet master server isn't actually listening on port 8081 even though the PuppetDB ...(more)

theillien gravatar imagetheillien ( 2013-09-18 14:25:09 -0600 )edit

I wonder if this is related: http://docs.puppetlabs.com/pe/latest/appendix.html#pe-install-fails-if-port-8080-or-8081-is-in-use I'm spinning up my POC silo for the third time, and trying out opening both ports.

atayarani gravatar imageatayarani ( 2013-09-18 15:00:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-18 15:50:33 -0600

It was a name resolution problem. The new puppet silo was trying to connect to the old puppetdb's IP using the new puppetdb's FQDN.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-18 12:31:06 -0600

Seen: 4,274 times

Last updated: Sep 19 '13