Ask Your Question
0

AWS Module issue with listing elb_loadbalancer resources

asked 2017-07-05 13:50:39 -0500

koakes gravatar image

updated 2017-07-05 13:52:29 -0500

Hello! I've been banging my head against the wall for a few hours now, and cannot figure out why the AWS module doesn't work for the loadbalancer code. The following happens to me:

sudo puppet resource elb_loadbalancer

Error: Could not run: Puppet detected a problem with the information returned from AWS when looking up elb_loadbalancer in ap-south-1. The specific error was:

The instance IDs 'redacted, redacted, redacted, redacted' do not exist

Rather than report on elb_loadbalancer resources in an inconsistent state we have exited. This could be because some other process is modifying AWS at the same time.

My EC2 console doesn't show anything in ap-south-1. No load balancers, none of the listed instances, nothing. All of the instances are in another load balancer in us-east-1, and everything looks fine there.

I'm sure I am just missing something, but I cannot figure out what it is. Any suggestions?

Edit: The aws module has worked for just about everything else I have done so far.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-05 15:37:37 -0500

koakes gravatar image

Ok, after just digging through the code, I have discovered that there is a bug in the load elb_loadbalancer module. I will be submitting a pull request with the fixes soon.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-05 13:50:39 -0500

Seen: 18 times

Last updated: Jul 05