pe-puppetdb throwing PostgreSQL 9.3 not longer supporter error on existing PostgreSQL 9.5 database

asked 2017-07-12 06:17:31 -0500

Currently I'm trying to install Puppet Enterprise on a server, which also runs JIRA and BitBucket. As JIRA also uses some ports (8080) that are also being used by some Puppet services, I've already changed those ports within the Puppet configuration files.

However, as I already had JIRA installed, there was an existing instance of PostgreSQL 9.5 installed in the server. When installing Puppet Enterprise through Monolith Install, I did select use an existing PostgreSQL database. It seemed like everything went through, even though the installer did say it failed. When doing a tail -f (or puppetdb foreground) I'm getting the following error from PuppetDB:

ERROR [p.p.c.services] ********************
*
* PostgreSQL 9.3 is no longer supported.  Please upgrade to 9.4.
*
********************

However, when I run psql --version it outputs:

psql (PostgreSQL) 9.5.7

When visiting the url Puppet is located on, it returns a 502 Bad Gateway error generated by Nginx.

The server is running on Ubuntu 16.04.02 LTS. As mentioned at the start, it's running alongside JIRA and BitBucket.

edit retag flag offensive close merge delete