Ask Your Question
0

install older version of puppet on Centos7

asked 2017-07-13 06:50:10 -0600

For some reasons I still have to stay with puppet versions 3 and 4 . As puppet agent must be lower or equal version to master server, I would like to know how to install older versions of puppet-agent on newly installled CentOS 7 machine ? I am trying to install from puppet release repo: rpm -Uvh http://yum.puppetlabs.com/puppet/pupp...

Currently in puppet repository I can see puppet-agent version 5 only and no prevoius versions so i cannot install and versionlock.

[root@puppet-test-vm ~]# yum --disablerepo "*" --enablerepo "puppet" --showduplicates list available Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile Available Packages puppet-agent.x86_64 5.0.0-1.el7 puppet puppet-release.noarch 1.0.0-1.el7 puppet puppet5-release.noarch 5.0.0-1.el7 puppet puppetdb.noarch 5.0.1-1.el7 puppet puppetdb-termini.noarch 5.0.1-1.el7 puppet puppetserver.noarch 5.0.0-1.el7 puppet

do you have any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-07-14 04:33:38 -0600

negast gravatar image

updated 2017-07-14 04:34:32 -0600

I would recommend upgrading to puppet 4 since 3 is eol. But it seems you were just using the wrong rpm to install the repo. Use this one for puppet 3 el 7 repo

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-07-13 06:50:10 -0600

Seen: 79 times

Last updated: Jul 14