Ask Your Question
0

Getting an 'Error: Facter: error while resolving custom fact "uid_min": invalid byte sequence in US-ASCII' after running puppet agent -t

asked 2017-07-27 06:19:22 -0500

joblack gravatar image

After running the puppet agent (5.0.0) with

root@lvpsasdf# puppet agent -t

Info: Using configured environment 'production'

Info: Retrieving pluginfacts

Info: Retrieving plugin

Info: Loading facts

Error: Facter: error while resolving custom fact "uid_min": invalid byte sequence in US-ASCII

The /etc/login.defs looks fine

root@lvpsasdf:/etc/apt/apt.conf.d# grep UID_MIN /etc/login.defs

UID_MIN 1000

The system is Debian 8 and it will probably use UTF8 but so are all the major new Linux distributions.

Any idea what's going on?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-07-27 07:39:15 -0500

joblack gravatar image

That worked. Thanks.

edit flag offensive delete link more
0

answered 2017-07-27 07:34:40 -0500

your machines encoding is set to ASCII, and you are trying to load a gemspec that contains UTF-8. Try setting the following and run puppet agent again?

LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-27 06:19:22 -0500

Seen: 29 times

Last updated: Jul 27