Ask Your Question
0

Puppet seach returns Error: Could not execute search (HTTP 301)

asked 2017-08-21 18:31:19 -0600

Anh gravatar image

updated 2017-08-22 15:01:38 -0600

Hi, I tried to search a module on http://forge.puppetlabs.com. I got "Error: Could not execute search (HTTP 301)".
It worked for the command puppet module install ntp. Any idea?

# puppet module search ntp Searching http://forge.puppetlabs.com ... Error: Could not execute search (HTTP 301) Error: Try 'puppet help module search' for usage

edit retag flag offensive close merge delete

Comments

I can't confirm any malfunction of PuppetForge, but it should read “Notice: Searching https://forgeapi.puppet.com ...” with an up-to-date Puppet. You aren't using some old Puppet version, are you?

Kai Burghardt gravatar imageKai Burghardt ( 2017-08-23 06:58:34 -0600 )edit
1

Anh wrote “I use the version of puppet - Puppet v2.7.25”. My reply: Yeah, then _upgrade_ your Puppet at least to some 4.x version [_kind_/friendly exclamation point]! PP 5.x has been released over a month ago. At some point it's really getting ridiculous to stay in the stone age.

Kai Burghardt gravatar imageKai Burghardt ( 2017-08-28 18:48:24 -0600 )edit

Puppet 2 was EoL'd on 09/2014, and Puppet 3 was EoL 12/31/16, so I wouldn't assume that they would still work with a modern version of the system.. If it does, great, but if it doesn't, you are pretty much on your own

DarylW gravatar imageDarylW ( 2017-08-29 07:33:53 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-08-28 18:39:20 -0600

Anh gravatar image

I use the version of puppet - Puppet v2.7.25

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-21 18:31:19 -0600

Seen: 37 times

Last updated: Aug 28