Installed puppet 5 and agent is not picking up the changes

asked 2017-08-29 09:10:57 -0600

semionie gravatar image

Hello,

I installed puppet 5 on the master and agent and signed the certificate for the agent, and all worked fine, now that i want a simple Hiera 5 test, i exactly followed the official docs from puppet at:

https://docs.puppet.com/puppet/5.0/hi...

to create a simple module "profile" that creates "hiera_test.txt" under /tmp ...And when i try to run a test from the agent:

puppet agent -t --environment production

Info: Using configured environment 'production' Info: Retrieving pluginfacts Info: Retrieving plugin Info: Caching catalog for xxxxx.domain Info: Applying configuration version '1504009389' Notice: Applied catalog in 0.04 seconds

But the hiera_test.txt is never created. Can anyone shed some light on what might be wrong here?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

I suggest you to post resource snippet along with error that will help to understand the issue.

rajeevsharma gravatar imagerajeevsharma ( 2017-08-31 07:10:52 -0600 )edit

This is the problem, there's no Error, after puppet agent -t it shows: Info: Using configured environment 'production' Info: Retrieving pluginfacts Info: Retrieving plugin Info: Caching catalog for xxxxx.domain Info: Applying configuration version '1504009389' Notice: Applied catalog in 0.04 secon

semionie gravatar imagesemionie ( 2017-09-01 08:05:03 -0600 )edit

there might be some glitch in your code. well, you can try running test in debug mode to find more.

rajeevsharma gravatar imagerajeevsharma ( 2017-09-15 03:40:40 -0600 )edit