Ask Your Question

Agent node disappeared from PE console

asked 2017-08-30 07:54:49 -0600

Mr_Sharma gravatar image

I have PE 2017.2.1 and 8 Agent nodes available. I have disabled my Agent to run on regular Basis or after a specific time interval. Puppet Agent run is done on On-demand.

I have noticed that when there are few days agent has not been executed (remain in idle mode) the node existance from PE console got disappeared. If I need to see that node again on PE console I need to run agent manually on that node. Why this is happening?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-08-31 12:30:52 -0600

reesek gravatar image

It sounds like you're running into the node-ttl.

This can be adjusted to suit your needs, as documented: "If unset, nodes are auto-expired after 7 days of inactivity. If set to 0s, auto-expiration of nodes is disabled"

edit flag offensive delete link more


Thank you for answering. But I am not able to do that. Do I need to set up a PostgreSQL Server? Since I am getting error: "The [database] classname setting has been retired and will be ignored." Any idea?

Mr_Sharma gravatar imageMr_Sharma ( 2017-09-01 05:31:10 -0600 )edit

In your originating question, you've indicated you have PE, so this would mean you have PuppetDB, which is your PostgreSQL. Login to your console, & select the PE PuppetDB node group. Chose the classes tab, & click the parameter drop down box & select node-ttl. Set it to the value you desire.

reesek gravatar imagereesek ( 2017-09-01 22:14:57 -0600 )edit

you may also override the value with hiera if you wish.

reesek gravatar imagereesek ( 2017-09-01 22:15:27 -0600 )edit

Thank you for your answer.

Mr_Sharma gravatar imageMr_Sharma ( 2017-09-19 02:28:50 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-08-30 07:54:49 -0600

Seen: 557 times

Last updated: Aug 31 '17