Puppet module install ignores requirements

asked 2017-09-04 06:18:35 -0500

I am trying to install a module via puppet module install.

puppet module install puppetlabs/apt

My current Puppet version is 3.7.2.

The downloaded module version of puppetlabs/apt at this point would be the 4.1.0.

The metadata.json of this module says the following:

"requirements": [
  {
    "name": "puppet",
    "version_requirement": ">= 4.7.0 < 5.0.0"
  }
]

My question: Is it a bug or something I am not seeing here, that makes puppet ignore the puppet version requirements?

Or does it simply not care, because puppet module install is not capable of checking out specific versions that meet certain requirements?

edit retag flag offensive close merge delete