I am getting Error 400 on SERVER: Syntax error at ':'; expected '}' at /etc/puppet/modules/phase60/manifests/params.pp:8 [closed]

asked 2017-09-12 01:24:50 -0500

shajics gravatar image

Here is the code for the same

################# Start of code

class phase60::params { case $::operatingsystem {

'OracleLinux': {
  case $::operatingsystemrelease {

    '7.3': {
      $os_packages = ['binutils:x86_64', 'compat-libcap1:x86_64', 'compat-libstdc++-33:x86_64', 'compat-libstdc++-33:i686', 'gcc:x86_64', 'gcc-c++:x86_64', 'glibc:i686', ]glibc:x86_64', 'glibc-devel:x86_64', 'glibc-devel:i686 ksh:x86_64', 'libgcc:i686', 'libgcc:x86_64', 'libstdc++:x86_64', 'libstdc++:i686', 'libstdc++-devel:x86_64', 'libstdc++-devel:i686', 'libaio:x86_64', 'libaio:i686', 'libaio-devel:x86_64', 'libaio-devel:i686', 'libXext:x86_64', 'libXext:i686', 'libXtst:x86_64 ', 'libXtst:i686', 'libX11:x86_64', 'libX11:i686', 'libXau:x86_64', 'libXau:i686', 'libxcb:x86_64', 'libxcb:i686', 'libXi:x86_64', 'libXi:i686', 'make:x86_64', 'sysstat:x86_64', 'nfs-utils:x86_64']
    }

    '6.8': {
      $os_packages = ['binutils:x86_64', 'compat-libcap1:x86_64', 'compat-libstdc++:i686', 'compat-libstdc++:x86_64', 'gcc:x86_64', 'gcc-c++:x86_64', 'glibc:x86_64', 'glibc:i686', 'glibc-devel:i686', 'glibc-devel:x86_64', 'ksh:x86_64', 'libgcc:i686', 'libgcc:x86_64', 'libstdc++:x86_64', 'libstdc++:i686', 'libstdc++-devel:x86_64', 'libstdc++-devel:i686', 'libaio:i686', 'libaio:x86_64', 'libaio-devel:x86_64', 'libaio-devel:i686', 'make:x86_64', 'sysstat:x86_64']
    }

    '6.5': {
      $os_packages = ['binutils:x86_64', 'compat-libcap1:x86_64', 'compat-libstdc++:i686', 'compat-libstdc++:x86_64', 'gcc:x86_64', 'gcc-c++:x86_64', 'glibc:x86_64', 'glibc:i686', 'glibc-devel:i686', 'glibc-devel:x86_64', 'ksh:x86_64', 'libgcc:i686', 'libgcc:x86_64', 'libstdc++:x86_64', 'libstdc++:i686', 'libstdc++-devel:x86_64', 'libstdc++-devel:i686', 'libaio:i686', 'libaio:x86_64', 'libaio-devel:x86_64', 'libaio-devel:i686', 'make:x86_64', 'sysstat:x86_64']
    }

    '6.3': {
      $os_packages = ['binutils:2.20.51.0.2-5.34.el6.x86_64', 'compat-libcap1:1.10-1.x86_64', 'compat-libstdc++-33:3.2.3-69.el6.i686', 'compat-libstdc++-33:3.2.3-69.el6.x86_64', 'gcc:4.4.6-4.el6.x86_64', 'gcc-c++:4.4.6-4.el6.x86_64', 'glibc:2.12-1.80.el6_3.6.x86_64', 'glibc:2.12-1.80.el6_3.6.i686', 'glibc-devel:2.12-1.80.el6_3.6.i686', 'glibc-devel:2.12-1.80.el6_3.6.x86_64', 'ksh:20100621-16.el6.x86_64', 'libgcc:4.4.6-4.el6.i686', 'libgcc:4.4.6-4.el6.x86_64', 'libstdc++:4.4.6-4.el6.x86_64', 'libstdc++:4.4.6-4.el6.i686', 'libstdc++-devel:4.4.6-4.el6.x86_64', 'libstdc++-devel:4.4.6-4.el6.i686', 'libaio:0.3.107-10.el6.i686', 'libaio:0.3.107-10.el6.x86_64', 'libaio-devel:0.3.107-10.el6.x86_64', 'libaio-devel:0.3.107-10.el6.i686', 'make:3.81-20.el6.x86_64', 'sysstat:9.0.4-20.el6.x86_64']
    }

    default: {
      $os_packages = ['binutils:2.20.51.0.2-5.34.el6.x86_64', 'compat-libcap1:1.10-1.x86_64', 'compat-libstdc++-33:3.2.3-69.el6.i686', 'compat-libstdc++-33:3.2.3-69.el6.x86_64', 'gcc:4.4.6-4.el6.x86_64', 'gcc-c++:4.4.6-4.el6.x86_64', 'glibc:2.12-1.80.el6_3.6.x86_64', 'glibc:2.12-1.80.el6_3.6.i686', 'glibc-devel:2.12-1.80.el6_3.6.i686', 'glibc-devel:2.12-1.80.el6_3.6.x86_64', 'ksh:20100621-16.el6.x86_64', 'libgcc:4.4.6-4.el6.i686', 'libgcc:4.4.6-4.el6.x86_64', 'libstdc++:4.4.6-4.el6.x86_64', 'libstdc++:4.4.6-4.el6.i686', 'libstdc++-devel:4.4.6-4.el6.x86_64', 'libstdc++-devel:4.4.6-4.el6.i686', 'libaio:0.3.107-10.el6.i686', 'libaio:0.3.107-10.el6.x86_64', 'libaio-devel:0.3.107-10.el6.x86_64', 'libaio-devel:0.3.107-10.el6.i686', 'make:3.81-20.el6.x86_64', 'sysstat:9.0.4-20.el6.x86_64']
    }
  }
}

default: {
  fail("Module phase60 does not support osfamily ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Kai Burghardt
close date 2017-09-19 11:07:00.531563

Comments

1

At the first appearance of `glibc:x86_64` you wrote a right square bracket as an opening string delimiter. This has gotta be a single quote `'`. That's something you would have seen _immediately_ in an editor with syntax highlighting, e.g. `vim-puppet`: https://github.com/voxpupuli/vim-puppet

Kai Burghardt gravatar imageKai Burghardt ( 2017-09-12 08:31:52 -0500 )edit

The issue was with ":" , it should have been a "." & it worked liked a charm.

shajics gravatar imageshajics ( 2017-09-19 07:05:12 -0500 )edit